Results 1 to 9 of 9

Thread: tdi lack of power

  1. #1
    Join Date
    Aug 2011
    Location
    glos
    Posts
    200

    tdi lack of power

    hi guys
    this is a strange one as no codes coming up whatsoever and literally one min it can drive perfect then the nxt it way down on power ive tried 2 new ecus and made no difference,fuel inj pump fine as been tested,ive done fuel filter air filter,
    I was wondering if could be throttle sensor or maf I have swapped maf but borrowed off a friend so not sure if gd any ideas be handy oh and def no vacline or hose issue

    just swapped throttle sensor no difference
    Last edited by dale p; 24-10-2018 at 03:21 PM.

  2. #2
    Join Date
    Aug 2011
    Location
    horncastle
    Posts
    295
    When it loses power have you tried switching it off and back on again?

  3. #3
    Join Date
    Jul 2010
    Location
    west midlands
    Posts
    3,771

  4. #4

  5. #5
    Join Date
    Aug 2011
    Location
    glos
    Posts
    200
    yea turned on off no different

    def not vanes as turbo new

  6. #6
    Join Date
    Dec 2017
    Location
    South lincs
    Posts
    16
    I can't remember if these have an EGR, but on on the PD in my car, the EGR being caked up was causing this problem. A delete kit fixed it nicely.

    As you've recently done a pretty major job (turbo replacement), it's worth going round and making sure you've not got a loose pin in an electrical plug or an vac hose giving a poor connection.

    Have you got the means to do a fault code read?

  7. #7
    Join Date
    Aug 2011
    Location
    glos
    Posts
    200
    yes all boost hoses fine,all vac lines fine
    yes no codes whatsoever
    ive noticed on tickover its fine but if you rev hard a few times it will start juddering and sounding rough and smokey then will settle back down

    egr deleted already and cleaned out inlet while off

  8. #8
    Join Date
    Dec 2009
    Location
    Inverness
    Posts
    620
    Start with the simple stuff and change the fuel filter

  9. #9
    Join Date
    Aug 2011
    Location
    glos
    Posts
    200
    done that at start lol
    looks like the issue is a shot cat

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •