Results 1 to 7 of 7

Thread: Wiring diagrams for 2001 SDI Engine and ECU

  1. #1
    Join Date
    Oct 2009
    Location
    Ireland
    Posts
    4

    Wiring diagrams for 2001 SDI Engine and ECU

    Hi,

    I was wondering if anyone had the wiring diagrams for the 2001 Seat Inca, VW Caddy SDI engine and ECU electronics.

    I have an intermittent problem with the car not starting. The 109 relay has been replaced with no improvement. THe local garage have diagnosed it as a faulty ECU but I would like to check out the wiring before going to the expense of replacing the ECU

    Thanks
    Tom

  2. #2
    Join Date
    Jun 2007
    Location
    Glasgow
    Posts
    2,437
    Nope! Yer wasting time here......IT IS AN ECU FAULT. The Master Tech I spoke to on mine, when I had the ECU fault said that it WAS a known fault in our models of Caddy, Vw were a ware of it but nothing was done, no recalls nowt........

    Sorry matey, but if you've plenty of time on your hands........

  3. #3
    Join Date
    Oct 2009
    Location
    Ireland
    Posts
    4
    Hello,

    Thanks for the answer even thought it was not what I wanted to hear . Was your fault intermittent or was the ECU totally dead?



    Tom

  4. #4
    Join Date
    Jun 2007
    Location
    Glasgow
    Posts
    2,437
    Well, on mine I thought I was totally unique and had my own fault, however I was wrong and someone else has the same on the board... I ran about for ages with a flashing Glowplug warning light and I always thought that that was the brake light warning failure, but I've since discovered that it also acts as your engine management light telling you there's a problem with the ECU, it can run "Out of Tolerance" for a while but eventually **POOF** Limp home mode! In your case you have the common and known fault - Non Starty! The Master Tech where I took my van to told me that this was the most common of faults and that the only way to repair it was a new ECU. He showed me a bundle of ECU's that all had the same fault lying on his bench to be used as test subjects... Unfortunately Tom they want around a grand for a new one, however there are two guys on Flea Bay that sell a reconditioned one and also a new one both are around the £100 mark but the part numbers Must be identical, its the old pairing of parts to vans/cars issue then you'll need to get your guy over there to clear the codes on the van and code the new ECU to the van - complicated in description but easy enough in reality.... HTH

    Good luck an keep at it, you'll win in the end....

  5. #5
    Join Date
    Oct 2009
    Location
    Ireland
    Posts
    4
    My problem is a little different in that when the van runs the heater plug light does not flash, just comes on as normal and goes out when the car starts. When the van does not run the light does not come on at all. It is still likely to be an ecu fault but I would like to rule out wiring problems etc first.

    Anyone with a wiring diagram?

    Tom

  6. #6
    Join Date
    Jun 2007
    Location
    Glasgow
    Posts
    2,437
    Try again Tom - see if you can source a spare or "Loan" ECU and try it, if it cures the fault then you know it to be the ECU if not then its the wiring. You do know that the ECU is located under the plastic valance on the drivers side (Looking onto the engine bay) and therefore will be sitting under leaves and about 1/2 inch of water as it floods there and causes the problem....

  7. #7
    Join Date
    Oct 2009
    Location
    Ireland
    Posts
    4
    Had a further look today and the ECU would not start at all. Connected a diagnostic cable and the Immobilizer responds but the ECU will not communicate with the diagnostics. Checked the 109 relay and it is working and the ouput goes to 12V when the ignition switch is turned on.


    Is there someone on this site who fixes / supplies ECUs?

    Tom

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •